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DPA - Remote Description 
DPA - Remote, Digi Port Authority - Remote, is a program to discover and monitor data and errors 
on Digi devices with either Digi’s proprietory program called ADDP (A Digi Discovery Protocol) or 
SNMP agents over TCP/IP. A network interface to a device might be an Ethernet or PPP connection.

Discovery
Discovery is a program that will discover Digi devices residing on a network. The Digi devices are 
discovered with either ADDP (A Digi Discovery Protocol) or with SNMP. For a Digi device to be 
discovered by ADDP, it must be ADDP enabled. For a Digi device to be discovered by SNMP, it 
must have SNMP enabled. See "ADDP Requirements" on page 1-2 and "SNMP Requirements" on 
page 1-2.

Network Interface Monitoring 
Monitoring a network interface can be helpful in troubleshooting network performance issues or 
keeping track of the network interface performance. DPA - Remote can monitor incoming and 
outgoing data and errors on a network interface.

Port Monitoring 
Monitoring ports can be helpful in troubleshooting port problems. DPA - Remote can monitor 
incoming and outgoing data and errors on ports. Also, individual signals (such as DTR, DCD, OFC, 
IFC, etc.) can be monitored. By viewing port signals, a user may be able to determine if a port 
appears to be functioning correctly or if it appears to be in some state of flow control or other 
condition of concern.

PortServer Products Supported
DPA - Remote supports Digi One RealPort, PortServer II, and PortServer TS products. Where this 
documentation uses the name PortServer, this implies any of these supported PortServer products. 
The original Digi PortServer is not supported.

Note: Depending on your PortServer model and firmware revision, the information displayed by 
DPA - Remote will differ.

Monitor Procedure
To begin monitoring a device, see "Device Monitor" on page 4-2.

Requirements

SNMP Requirements

An SNMP agent must be running on your supported Digi device before you can use DPA - Remote 
to monitor it. 

To start the SNMP agent, see the appropriate documentation for your particular Digi device. 

ADDP Requirements

ADDP stands for A Digi Discovery Protocol and runs on any operating system capable of sending 
multicast IP packets on a network. It allows the system to identify all ADDP enabled Digi devices 
attached to a network by sending out a multicast packet. The Digi devices respond to the multicast 
packet and identify themselves to the client sending the multicast. The ADDP protocol needs to 
communicate with the TCP/IP stack using the UDP protocol. The TCP/IP stack should be able to 
receive multicast packets and transmit datagrams on a network. Not all Digi devices support ADDP.



Introduction to DPA - Remote 1-3

Hardware Requirements

Using the Keyboard Instead of a Mouse

The DPA - Remote utility includes keyboard support for users with no access to a mouse or a 
preference for a keyboard. However, not all operating systems support these functions.

The TAB, SHIFT-TAB and arrow keys can be used to navigate the interface. Also available for use 
are the "ALT" keystroke combinations. For example, ALT-F will bring up the File menu and ALT-O 
will bring up the Options menu from the main monitoring window.

Where this documentation directs a user to select, choose or click, keyboard users are expected to 
use the appropriate keystrokes to accomplish the same task.A mouse may be required on some 
operating systems. Tab, and in particular, Shift-Tab, may not work correctly under all operating 
systems.
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Installing the Software: CD
Use this procedure to install software or a driver from the Digi RealPortCD. You should have 
already started the Digi RealPort CD front-end program.

Procedure
1. Choose an operating system.
2. Choose the Hardware product name. 
3. Choose Digi Port Authority - Remote. 
4. Choose Install Software. 
5. Follow the prompts. 
6. Reboot your system if necessary. 

Installing the Software: Downloaded
Use the procedures that follows to install a copy of Digi Port Authority - Remote that you have 
downloaded from the Digi web or FTP sites. 

Prerequisites
• On UNIX installations, an X-Window environment must be installed in order to run DPA - 

Remote. 

• On all installations, a web browser is required in order to display the help. 

• Linux users must create symbolic links before DPA - Remote will install properly. See "Pro-
cedure: Linux (RPM Method)" on page 2-3 and "Procedure: Linux (from Source)" on page 
2-3 

Procedures

Choose your operating system from the list below to jump to the appropriate installation procedure. 

• "Procedure: AIX" on page 2-2

• "Procedure: HP-UX" on page 2-2

• "Procedure: Linux (RPM Method)" on page 2-3

• "Procedure: Linux (from Source)" on page 2-3

• "Procedure: Microsoft Windows" on page 2-3

• "Procedure: SCO OpenServer" on page 2-3

• "Procedure: SCO UnixWare" on page 2-3

• "Procedure: Solaris" on page 2-4

Procedure: AIX
1. If you have previously installed a version of DPA - Remote, remove it by issuing the follow-

ing command: 
installp -u digidpar.dpar.obj 

2. Place the downloaded distribution file into the /tmp directory. 
3. Enter the following commands:

uncompress 40002192_version.installp.Z
installp -ad /tmp/40002192_version.installp digidpar 

Procedure: HP-UX
1. Place the downloaded distribution file into the /tmp directory. 
2. Enter the following commands: 

tar xvf 40002193_version.tar
/usr/sbin/swreg -l depot /tmp/digidpar.pkg
/usr/sbin/swinstall -s /tmp/digidpar.pkg 

3. Choose the line item, digidpar. 
4. Choose Actions > Mark for install. 



Installation 2-3

5. Choose Actions > Install (analysis). 
6. In the Install Analysis window, choose OK. 
7. Follow the prompts. 

Procedure: Linux (RPM Method)
1. Place the downloaded distribution file in a directory, such as /usr/src. 
2. Verify the following directory exists: 

/usr/src/linux
if not, create a symbolic link by entering the following command:
ln -s /usr/src/linux-(version number) /usr/src/linux 
where version number is the number of the Linux kernel. 

3. All Linux versions except RedHat must create the following symbolic link for the RPM to 
install properly. Enter the following command: 
ln -s /usr/src/(RPM source directory) /usr/src/redhat 
where the RPM source directory is the specific name used by your Linux distribution. 

4. Enter the following commands: 
rpm -ivv 40002188_version.src.rpm
cd /usr/src/redhat/SPECS
rpm -bb digidpar-version.spec
cd /usr/src/redhat/RPMS/<arch>
rpm -ivv digidpar-version.<arch>.rpm 

Procedure: Linux (from Source)
1. Place the downloaded distribution file in a directory, such as /usr/src. 
2. Verify the following directory exists: 

/usr/src/linux
if not, create a symbolic link by entering the following command:
ln -s /usr/src/linux-(version number) /usr/src/linux 
where version number is the number of the Linux kernel. 

3. Enter the following commands: 
cd /usr/src
tar -xvzf 40002188_version.tgz
cd digidpar-version/sme
make install
make link 

Note: It is recommended that you do not remove the source tree, since the makefiles are necessary 
for the uninstall procedure. 

Procedure: Microsoft Windows
1. Place the downloaded distribution file in a directory, or on the Windows desktop. 
2. Run the executable distribution file. Follow the prompts to install the software. 

Procedure: SCO OpenServer
1. Place the downloaded distribution file into the /tmp directory. 
2. Enter the following command: 

custom -i -p misc:digidpar -F /tmp/40002190_version.bin 

Procedure: SCO UnixWare
1. Place the downloaded distribution file into the /tmp directory. 
2. Enter the following command: 

pkgadd -d /tmp/40002189_<version>.pkg 
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Procedure: Solaris
1. Place the downloaded distribution file into the /tmp directory. 
2. Enter the following commands: 

uncompress /tmp/40002191_version.pkg.Z
pkgadd -d /tmp/40002191_version.pkg 

Uninstalling the Software
Use the procedures that follow to remove Digi Port Authority - Remote from your system. 

Procedures

Choose your operating system from the list below to jump to the appropriate uninstall procedure. 

• "Procedure: AIX" on page 2-4

• "Procedure: HP-UX" on page 2-4

• "Procedure: Linux (RPM Method)" on page 2-4

• "Procedure: Linux (from Source)" on page 2-4

• "Procedure: Microsoft Windows" on page 2-4

• "Procedure: SCO OpenServer" on page 2-5

• "Procedure: SCO UnixWare" on page 2-5

• "Procedure: Solaris" on page 2-5

Procedure: AIX
Enter the following command:
installp -u digidpar.dpar.obj 

Procedure: HP-UX
1. Enter this command at a root prompt: 

swremove 
The SD - Remove Software Selection window appears. 

2. Choose digidpar. 
3. Choose Actions > Remove (Analysis)... 
4. Choose OK to continue at the Remove Analysis window. 
5. Choose Yes at the Confirmation windows that appear. 
6. Choose Done at the Remove window. 
7. Confirm the prompt to reboot the system when it appears. If it does not appear, the system 

should be rebooted manually. 

Procedure: Linux (RPM Method)
Enter the following command:
rpm -e digidpar

Procedure: Linux (from Source)
Enter the following commands:
cd /usr/src/digidpar-version/sme
make unlink
make uninstall

Procedure: Microsoft Windows
1. From the Start menu, choose Settings > Control Panel > Add/Remove Programs. 
2. Choose Digi Port Authority - Remote. 
3. Choose Remove. 
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Procedure: SCO OpenServer
Enter the following command:
custom -r misc:digidpar

Procedure: SCO UnixWare
Enter the following command:
pkgrm digidpar

Procedure: Solaris
Enter the following command:
pkgrm digidpar
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Starting the DPA - Remote 
Use the following procedures to start Digi Port Authority - Remote.

Microsoft Windows

From the Start menu, choose Programs > Digi > Digi Port Authority - Remote.

UNIX

Enter the following command:

dparemote

DPA - Remote Main Window
Use this topic to learn more about using the DPA - Remote. 

The DPA - Remote Control Panel consists of these items:

Various options are also available also by going to File > Options. Three options are available:

Item Function

Device Monitor Choose the Device Monitor to monitor interfaces and ports on Digi devices.

Device Configuration Choose the Device Configuration to launch a browser and configure your Digi device with the 
Web interface provided this feature is supported on your device.

Most Recent This lists the most recent devices monitored or configured with DPA - Remote.

Discovered Devices This table displays all the devices discovered by either the ADDP or the SNMP protocols. 

Discovery Protocol Choose either ADDP or SNMP to discover devices attached to your network.

Discover Launches another search for devices using either ADDP or SNMP protocols.

Save Saves a list of Discovered devices.

Criteria The Criteria button appears when the SNMP radio button is checked. Choose Criteria to modify 
SNMP Discovery requests. 

Clear Item Clears a single highlighted device from the Discovery Devices list.

Clear All Clears all devices from the Discovery Devices list.

Item Function

Global Allows the user to change location of program data, modify Most Recent list, and enable/dis-
able Domain Name Resolver.

Discovery Modify the Discovery options such as SNMP Throttle.

Device Monitor Modifies font sizes, timers, and graph scales displayed by the Device Monitor.



Administration: DPA - Remote 4-1

chapter 4 Administration: DPA - Remote

• Device Monitor . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2

• Selecting the Device Community . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2

• Device Configuration  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2

• Most Recent  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-3

• Discovered Devices. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-3

• Discovery Protocol . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-3



 4-2 Device Monitor

Device Monitor
Use this procedure to monitor network interfaces and ports and display information regarding your 
Digi device. 

Procedure
1. From the Device Monitor area, enter the DNS name or the IP address of the Digi device.

You can also monitor a device by choosing a device from the Discovered Devices or Most 
Recent lists.

2. From the Community drop-down box, choose the appropriate device community. See 
"Selecting the Device Community" on page 4-2

3. Choose Monitor. 
The main monitoring window appears. Should an error message occur when DPA - Remote 
is attempting to connect to the device, see"Connection Errors" on page 6-2 .

4. Choose the Display Information tab to view information on the Digi device.
5. Choose the Network Interface and Ports tab to view the network interface and ports. Multiple 

interfaces and ports may be selected at the same time. For more information, see "Main Mon-
itor Window" on page 5-2. 
A new monitor frame appears for each network interface or port you select. 
To close a monitor frame, click the network interface or port button associated with that 
frame. 

6. Monitor the network interfaces or ports. For more information on the network interface and 
port monitoring fields and graphs, see "Network Interface Monitor Fields and Graphs" on 
page 5-3 and "Port Monitor Fields and Graphs" on page 5-4. 

7. Choose Modbus Information to view information displayed about the Digi Modbus device. 
Note: This tab will not appear on systems that do not support Modbus.

Selecting the Device Community
Use this topic to learn more about selecting the device Community field.

The SNMP community field defines the relationship between a device running SNMP and the DPA 
- Remote interface. This field acts like a password to control DPA - Remote access to the device.

DPA - Remote Community Options

Device Configuration
1. From the Device Configuration area, enter the DNS name or the IP address of the Digi 

device. 
You can also choose a device from the Discovered Devices or Most Recent lists.

2. Choose Configure. A browser opens allowing you to configure your Digi device. 
3. Enter at the User Name: 

root 
and at the password enter:
dbps

Option SNMP Access

public
Digi device's default community for read-only access. If this has been changed in the device configuration 
(see "Changing the SNMP Community on a Digi Device" on page 5-2), choosing this option will not have 
the desired effect, and you must instead choose <user-defined> and enter the appropriate community name.

private
Digi device's default community for read/write access. If this has been changed in the PortServer (see 
"Changing the SNMP Community on a Digi Device" on page 5-2), choosing this option will not have the 
desired effect, and you must instead choose <user-defined> and enter the appropriate community name. 

<user-
defined>

Custom read or write access as defined on the Digi Devicer. This requires that the SNMP community 
entered has been previously defined on the device being monitored. See "Changing the SNMP Community 
on a Digi Device" on page 5-2
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Most Recent
The Most Recent box contains a list of the IP addresses or DNS name of the most recent devices 
monitored with DPA - Remote. This list’s length can be modified by going to File > Options and 
choosing the General Options tab. The buttons will allow you to increase or decrease the number of 
devices listed.

Discovered Devices
This box displays devices discovered on the network with either the ADDP or the SNMP protocol. 
The discovery process can be modified for both ADDP and the SNMP protocols by going to File > 
Options.

Modifying ADDP Discovery Process

The discovery of ADDP devices can be modified in the File > Options menu. 

• ADDP can be modified under the General Options tab by selecting or deselecting the Enable 
name resolver. Deselecting the Enable name resolver box will improve system performance 
by not waiting to resolve DNS names. Selecting the box displays DNS names, if applicable, 
but may slow the discovery process on Microsoft Windows systems.

• ADDP can be modified under the Discovery Options tab by choosing Auto Discover on star-
tup and also by choosing Pre-select ADDP discovery.

Modifying SNMP Discovery Process

The discovery of SNMP devices can be modified in several different ways. You can modify the 
SNMP Throttle or the detection of the local subnet by going to File > Options and choosing the 
Discovery Options tab. SNMP Throttle controls the number of SNMP requests made per second on 
the network. Setting the SNMP Throttle too high may overwhelm the network and seriously hinder 
network performance.

You can also modify the SNMP discovery process by going to Discovery Protocol, checking the 
SNMP button and then choosing Criteria. This allows the user to modify what IP addresses or range 
of IP addresses an SNMP discovery search should be made.

Discovery Protocol
The two options are ADDP or SNMP. ADDP stands for A Digi Discovery Protocol and allows the 
system to identify all the Digi devices attached to a network by sending out a multicast packet. If a 
Digi device has ADDP it will respond to the multicast packet and identify itself to the application 
sending the multicast.

An SNMP agent must be running on your supported PortServer device before you can use DPA - 
Remote to discover it. SNMP Discovery sends an SNMP request to each node, but throttles the 
speed at which the packets are sent out to prevent your network from being flooded with requests. 
When the SNMP protocol is selected, the Criteria button will appear allowing modifications to the 
SNMP discovery search.
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Main Monitor Window
Use this topic to learn more about the DPA - Remote main monitor window fields and controls. This 
screen is accessed by choosing Monitor from the Device Monitor field on the Control Panel. To 
close this screen, use the ESC key.

Fields and Controls

Field Description

Device Name The name of the device, if defined (see the set device command in the Command Reference 
Guide for information on defining device names).

Node The node name or IP address of the device.

Device Description Describes the device. The description may include the firmware version of the device.

Variable Power Fields Two power sources are available, either Powered Ethernet or an external power supply. The 
options are engaged or disabled.

Processor Utilization 
(PortServer TS 8/16 
Only)

The Processor Utilization graph shows the current CPU utilization as a percentage. 100% 
indicates completely busy; 0% indicates completely idle. The graph is updated from the 
right, at the interval defined in Options > Poll Interval. 

Memory Utilization 
(PortServer TS 8/16 
Only)

The Memory Utilization graph shows the current CPU utilization as a percentage. 100% 
indicates all available memory is being used. The graph is updated from the right, at the 
interval defined in Options > Poll Interval. 
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Network Interface Monitor Fields and Graphs
Use these tables to learn more about the network interface fields and graph. 

Topics
• "Interface Information Fields" on page 5-3

• "Input Counter Fields" on page 5-3

• "Output Counter Fields" on page 5-4

• "Octets In/Octets Out Monitor" on page 5-4

Interface Information Fields

Input Counter Fields

Field Description

Description 
A text string containing information about the interface. 
This string usually includes the name of the manufacturer, the product name and the version of the 
hardware interface.

Physical 
Address

The address of the interface at the protocol layer immediately below the network layer in the protocol 
stack. 
For interfaces that do not have such an address (e.g., a serial line), this object should contain an octet 
string of zero length. 

Speed

The speed of the network interface in bits per second. 
For interfaces that do not vary in bandwidth or for those where no accurate estimation can be made, 
this object should contain the nominal bandwidth. 
A PPP connection will report a speed of zero until the connection is up.

MTU
The size of the largest datagram which can be sent/received on the interface, specified in octets. 
For interfaces that are used for transmitting network datagrams, this is the size of the largest network 
datagram that can be sent on the interface. 

Field Description

Unicast Packets The number of input unicast packets received. 
Unicast is the method by which a packet is sent to a single destination. 

Non-Unicast 
Packets The number of non-unicast (i.e., subnetwork-broadcast or subnetwork-multicast) packets received.

Total Octets In The total number of octets received on the interface, including framing characters.

Discarded Pack-
ets

The number of inbound packets which were discarded. 
One possible reason for discarding packets is to free up buffer space. This field will show a red back-
ground if an error has occurred in the last poll interval.

Packet Errors The number of received packets containing errors. 
This field will show a red background if an error has occurred in the last poll interval.

Unknown Proto-
cols

The number of packets received via the interface which were discarded because of an unknown or 
unsupported protocol.
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Output Counter Fields

Octets In/Octets Out Monitor

The Octets In/Octets Out graphs show the number of octets received (Octets In) and transmitted 
(Octets Out) by the interface. The graphs update from right-to-left and represent the percentage of 
line speed over the last 20 poll intervals. 

The scale of the graphs can be changed by choosing Options > Graph Scale > Network from the 
Monitor Window menu. 

The poll interval of the graphs can be changed by choosing Options > Poll Interval from the Monitor 
Window menu. The valid range is from 1-60 seconds. The poll interval determines how frequently 
the interface is polled for information. 

Port Monitor Fields and Graphs
Use this topic to learn more about the port monitor fields and graphs. 

Topics
• "Port Monitor Fields" on page 5-4

• "Signal Monitor" on page 5-5

• "Characters In/Characters Out Monitor" on page 5-5

Port Monitor Fields

Field Description

Unicast Packets The number of output unicast packets sent. 
Unicast is the method by which a packet is sent to a single destination. 

Non-Unicast Pack-
ets The number of non-unicast (i.e., subnetwork-broadcast or subnetwork-multicast) packets sent.

Total Octets Out The total number of octets sent on the interface, including framing characters.

Discarded Packets
The number of outbound packets which were discarded. 
One possible reason for discarding packets is to free up buffer space. This field will show a red 
background if an error has occurred in the last poll interval.

Packet Errors The number of sent packets containing errors. 
This field will show a red background if an error has occurred in the last poll interval.

Field Description

Type The type of port selected.

Speed The speed of the port in bits per second.

Input Flow Control The input flow control of the port. 
Examples: none, xonXoff or ctsRts

Output Flow Con-
trol

The output flow control of the port. 
Examples: none, xonXoff or ctsRts

Character Bits The number of bits in a character. 
Examples: 8 or 7

Stop Bits The number of stop bits. 
Examples: one, two or oneAndHalf

Parity The type of parity. 
Examples: none, odd or even 
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Signal Monitor

This section of the port monitor window shows the status of various EIA-232 signals on the selected 
port. Active (on) signals are shown in green and inactive (off) signals in black. 

EIA-232 Signal Descriptions

Characters In/Characters Out Monitor

The Character In/Character Out graphs show the number of characters received (Characters In) and 
transmitted (Characters Out) by the port. The graphs update from right-to-left and represent the 
percentage of line speed over the last 20 poll intervals. The poll interval determines how frequently 
the port is polled for information. Poll intervals apply to all data, not just graphs.

Device Monitor Options

Fonts, timers, and graph scaling can be modified for the Device Monitor by going to File > Options 
> Device Monitor.

Parity Errors
The total number of characters with a parity error, input from the port since system re-initializa-
tion and while the port state was 'up' or 'test'. 
This field will show a red background if an error has occurred in the last poll interval.

Overrun Errors
The total number of characters with an overrun error, input from the port since system re-initial-
ization and while the port state was 'up' or 'test'. 
This field will show a red background if an error has occurred in the last poll interval.

Framing Errors
The total number of characters with a framing error, input from the port since system re-initializa-
tion and while the port state was 'up' or 'test'. 
This field will show a red background if an error has occurred in the last poll interval.

MEI Settings Displays the devices MEI settings, usually on port 1 only.

Total Characters In The total number of characters received by the port.

Total Characters 
Out The total number of characters transmitted by the port.

Signal Description

RTS Request to Send

CTS Clear to Send

DSR Data Set Ready

DCD Data Carrier Detect

DTR Data Terminal Ready

RI Ring Indicator

OFC Output is Flow Controlled

IFC Input is Flow Controlled
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Connection Errors
Use this topic to learn more about DPA - Remote connection errors.

During the course of connecting to or monitoring a device, error windows may appear if DPA - 
Remote cannot properly communicate with the device. These errors may point to a problem with the 
device or the network connection between the device and DPA - Remote. The device may simply be 
powered off or disconnected from the network.

If you get a connection error, verify these things.

• The IP address you specified is correct for the device 

• The IP address for the device is unique on your network 

• The device is powered-on and properly connected to your network 

• You can ping or telnet to the device 

• The SNMP daemon is running on your device.

• The value in the community field you use (when selecting a device to monitor) matches the 
actual read or write community value defined on the device. 

If DPA - Remote can not discover your device, it can be due to one of following reasons:

• The Digi device may have old firmware.

• ADDP or SNMP may not be supported on the device.

• There may be a network problem.


